# Fresh LXD container installation of fdb 6.0.15 fails with Database unavailable

**URL:** https://forums.foundationdb.org/t/fresh-lxd-container-installation-of-fdb-6-0-15-fails-with-database-unavailable/932
**Category:** Using FoundationDB
**Created:** [December 4, 2018, 10:08am UTC](https://forums.foundationdb.org/t/fresh-lxd-container-installation-of-fdb-6-0-15-fails-with-database-unavailable/932 "2018-12-04T10:08:08Z")
**Posts on this page:** 1
**Showing post:** 3

<div class="post-metadata">

### Author: ![cloudspeech](https://sea1.discourse-cdn.com/foundationdb/user_avatar/forums.foundationdb.org/cloudspeech/32/330_2.png) [@cloudspeech](https://forums.foundationdb.org/u/cloudspeech)
#### Post date: [December 4, 2018, 2:53pm UTC](https://forums.foundationdb.org/t/fresh-lxd-container-installation-of-fdb-6-0-15-fails-with-database-unavailable/932/3 "2018-12-04T14:53:19Z")

</div>

The issue is indeed resolved by using a LXD storage-pool type that is compatible with foundationDB (cf. [https://lxd.readthedocs.io/en/latest/storage/](https://lxd.readthedocs.io/en/latest/storage/)).

For example, LVM with underlying ext4 works.

(For those, who - like me - want to preserve their precious container content but just get foundationDB to work:  
lxc storage create lvm lvm  
lxc profile copy default fdb  
lxc profile edit fdb # change ‘pool’ value to ‘lvm’ in editor  
lxc stop my-container  
lxc copy my-container fdb-container --container-only --profile fdb  
lxc start fdb-container

You may have to apply the advice from [Trying to make docker image; fdbcli says database not created](https://forums.foundationdb.org/t/trying-to-make-docker-image-fdbcli-says-database-not-created/157/2) after that.  
)

---

_[View the full topic](https://forums.foundationdb.org/t/fresh-lxd-container-installation-of-fdb-6-0-15-fails-with-database-unavailable/932)._
