Fdb-joshua: unable to run docker container, on aws ec2 instance (ubuntu)

I’m trying to setup and run the docker container for fdb-joshua in order to run their testing infrastructure: GitHub - FoundationDB/fdb-joshua: FoundationDB Correctness service

I’ve built their docker image via:


docker images are there from the ./build.sh file:

(python3) ubuntu@random-computer:~/fdb-6.3/build$ docker images
REPOSITORY                  TAG                         IMAGE ID       CREATED          SIZE
foundationdb/agent-scaler   20220125191625-e1ef13f681   961240cf5491   35 minutes ago   336MB
foundationdb/agent-scaler   latest                      961240cf5491   35 minutes ago   336MB
foundationdb/joshua-agent   20220125191625-e1ef13f681   cf59afc5b719   36 minutes ago   3.37GB
foundationdb/joshua-agent   latest                      cf59afc5b719   36 minutes ago   3.37GB
centos                      7                           eeb6ee3f44bd   4 months ago     204MB
centos                      latest                      5d0da3dc9764   4 months ago     231MB

To start agents, I run:

sudo docker run --rm -v /home/ubuntu/fdb-6.3/build/fdb.cluster:/opt/joshua -it foundationdb/joshua-agent:latest

but I get this error:

docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: rootfs_linux.go:76: mounting "/home/ubuntu/fdb-6.3/build/fdb.cluster" to rootfs at "/opt/joshua" caused: mount through procfd: not a directory: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type.

I’ve tried unmounting the volume from the image, but still getting the issue. Can someone help me with this? Any pointers are appreciated. Thanks!

It seems the error is complaining the mount path. Try to use /home/ubuntu/fdb-6.3/build/ instead. The idea is that /opt/joshua/fdb.cluster inside the docker points the cluster file.

inside the build.sh file, there is a env var, FDB_VERSION so we need to run the build like so:

./build.sh FDB_VERSION=6.3.21

then I was able to get the run my image:

docker run --rm --env FDB_CLUSTER_FILE=/opt/joshua/fdb.cluster -v /home/ubuntu/fdb-6.3/build/:/opt/joshua -it foundationdb/joshua-agent:latest