How to troubleshoot foundation db 6.0 startup issue

(Srinivas k) #1

I have installed fdb 6.0 on Ubuntu 16.04.3 LTS and seeing below error message when checking for status.

Using cluster file `/etc/foundationdb/fdb.cluster’.

The database is unavailable; type `status’ for more information.

Welcome to the fdbcli. For help, type `help’.
fdb> status

Using cluster file `/etc/foundationdb/fdb.cluster’.

Requesting information from coordination servers. Verify that a majority of
coordination server processes are active.

127.0.0.1:4500 (reachable)

Error log shows

"Event Severity=“40” Time=“1558321678.831541” Type=“SystemError” ID=“0000000000000000” Error=“internal_error” ErrorDescription=“An internal error occurred” Err orCode=“4100” Backtrace=“addr2line -e fdbserver.debug -p -C -f -i 0x1428186 0x14268f7 0x13e60ea 0x13e635e 0x9bb7d8 0x9bbb4a 0x9bbff1 0x5c0898 0x5d696e 0x5d7461 0x5cfb10 0x5cfce3 0x5cf1b0 0x5cf547 0x5cf711 0x465be0 0x463348 0x465be0 0x5cc228 0x5cf1b0 0x5c5317 0x5c550e 0x5cf1b0 0x5c5a90 0x5c5d03 0x5cf1b0 0x5c72d2 0x5cf 1b0 0x5c5f06 0x5cf1b0 0x5d806a 0x135ecd8 0x135ef29 0x52dc30 0x144c8fa 0x43a7f0 0x7f9a7707d830” Machine=“127.0.0.1:4500” LogGroup=“default” Roles=“CC,MS,SS” />
<Event Severity=“10” Time=“1558321678.832829” Type=“Role” ID=“317c74acd062f105” Error=“internal_error” ErrorDescription=“An internal error occurred” ErrorCode= “4100” Transition=“End” As=“MasterServer” Reason=“Error” Machine=“127.0.0.1:4500” LogGroup=“default” Roles=“CC,MS,SS” TrackLatestType=“Original”

Any help on troubleshooting this is appreciated. Thanks in advance.

Srinivas K

(A.J. Beamon) #2

Having not looked too deeply into this, it appears the line that’s failing is complaining about an old protocol version. Is there any chance that you are or have run some processes with an old version (say, before 5.0) that may have some state lying around?

Also, is the version you are currently trying to run v6.0.18? That’s the version I used to get the backtrace, but if that’s not right it could change things.

(Srinivas k) #3

Thanks for looking into it. I was running fdb 3.0 version earlier. As i couldn’t find a way to upgrade to 6.0 i have uninstalled 3.0 server,client packages and did a fresh install of 6.0 packages.

(A.J. Beamon) #4

Glad you were able to get things working. Upgrades from 3.0 were supported in 5.0, and maybe sometime as late as 5.2, but they are not supported anymore in 6.0.

If you really needed to upgrade from an old version, it should be possible to do so by first upgrading to 5.0 and then from 5.0 to 6.0. Awkwardly, it doesn’t seem that there are download links for older versions on the website, so if you had such a need you’d probably need to build it yourself or maybe work with us to get a copy of the binaries.

(Srinivas k) #5

Sorry i couldn’t make it work, i still get same error. In my earlier comment I meant: as i couldn’t find the upgrade path from 3.0 to 6.0, i have uninstalled 3.0 and installed 6.0 packages. Any way’s this issue can be closed as i have rebuilt entire setup with fdb 6.0 fresh install.

(A.J. Beamon) #6

Deleting your 3.0 install and reinstalling 6.0 is certainly valid if you don’t care about your data. My comment was more to explain why the upgrade from 3.0 to 6.0 didn’t just work and how one might be able to do it if they didn’t want to lose existing data.

If you’re saying that you tried upgrading from 3.0 to 5.0 (rather than 6.0) unsuccessfully, that would be unexpected. It’s probably not an upgrade many people will be trying, but if you were running into trouble here and have details to share about how it failed, it may be helpful if something like this happens in the future.

If you only had problems upgrading directly from 3.0 to 6.0, then that is expected as described above.