Record Layer Java 11 Dependency Upgrade

At the moment, the Record Layer currently has Java 8 as its current source and binary compatibility target, though it uses the Java 11 compiler to build and is already compatible with a Java 11 runtime. We are considering updating the target binary version up to Java 11 in a future release, which means that software running on older JVMs will no longer be able to use newer Record Layer versions. Before we make this change, we first wanted to solicit feedback from the community in case there are users who have specific concerns or for whom this would be a particularly disruptive change. Please let us know if you are in that category.

2 Likes