Turn off database creation in install

I’ve had problems trying to install FDB with DEBs built from master into a Docker container where everything seems to work except for configure new single memory. My guess is that the problem is that I’m building the images on an underpowered Mac laptop. As a workaround, I’ve installed released images first to set up the database before installing the new images. Is there a way to just disable the call to configure new single memory since I need to reconfigure the database before deploying regardless?

If you create /etc/foundationdb/fdb.cluster the post-install script won’t try to create a new database.

Basically, you can just run this:

getent group foundationdb >/dev/null || addgroup --system foundationdb
getent passwd foundationdb >/dev/null || adduser --system --disabled-login --ingroup foundationdb --no-create-home --home /var/lib/foundationdb --gecos "FoundationDB" --shell /bin/false foundationdb

chown -R foundationdb:foundationdb /var/lib/foundationdb /var/log/foundationdb
chmod -R 0700 /var/lib/foundationdb/data /var/log/foundationdb

description=`LC_CTYPE=C tr -dc A-Za-z0-9 < /dev/urandom | head -c 8`
random_str=`LC_CTYPE=C tr -dc A-Za-z0-9 < /dev/urandom | head -c 8`
echo $description:$random_str@ > /etc/foundationdb/fdb.cluster
chown foundationdb:foundationdb /etc/foundationdb/fdb.cluster
chmod 0664 /etc/foundationdb/fdb.cluster
1 Like