Operator v1.0.0 ignores volumeClaim spec

After upgrading CRD definitions and fdb operator in a test environment, the operator started a migration to a new set of pods, with a different storage class and storage size from what the old cluster had.

This is the volumeClaim we have used:

      ... more fields here ...
              storage: 512Gi
          storageClassName: ssd-retain

This worked before, but after upgrading to the new CRD, it seems that this field is removed from the cluster spec, and the operator creates pods with size 120Gi and using the default storage class.

I guess the only change needed is to rename to volumeClaimTemplate. I tried to run the kubectl-fdb plugin to check for deprecations, but it just failed to authenticate to both azure and gcp. I should have spotted this anyway though. I will look into other ways of verifying the cluster spec.

I think I know what is missing and I can provide a patch for this. At least newer version of the plugin will then be able to authenticate against Azure and GCP.

And you’re right the only required change is renaming “volumeClaim” to “volumeClaimTemplate”.

1 Like