Starting/Stoping the Server

(Zoe) #1

I’m installing foundationDB on Amazon Linux AMI built on Centos. I could run the command to install the two rpm packages but it didn’t seem to start the server for me. I have to manually run
sudo /usr/sbin/fdbserver -p 127.0.0.1:4500
to start the server and
configure new single memory
to get the database running. Then every time I have to manually start the server.

Am I missing something here? During installation the client side stuck at 50% but no error message is displayed. I also tried
sudo chkconfig foundationdb off
as indicated in your tutorial and the folllowing error pop up:
error reading information on service foundationdb: No such file or directory

Thank you!

(A.J. Beamon) #2

I’ve seen a similar sort of problem with the deb packages in Ubuntu:

I think it does manage to start fdbmonitor, though. Are you not seeing that happen at all? If you get fdbmonitor but not fdbserver, you could check syslog and let us know if you see any errors related to fdbserver.

I don’t really have much experience with using our rpm packages in CentOS, but in theory installing the package is supposed to start the fdb service, which will run fdbmonitor. Then fdbmonitor will start an fdbserver process based on what’s specified by default in the foundationdb.conf file. Finally, the installation should try to configure the cluster. At the end of all of this, the expectation is that you would have a working single-process cluster.

(Zoe) #3

Thank you for getting back, so how do I check if fdbmonitor has started yet?
And what’s the best place here to check logs from installation? I’ve looked up var/log/secure and var/log/foundationdb/ but couldn’t find any error logs…

Thank you!

(A.J. Beamon) #4

Easiest way is to check for a running fdbmonitor process (e.g. ps -ef | grep fdbmonitor).

The logs I referred to above are logged by fdbmonitor using the standard syslog facility. On my machine, these end up in /var/log/syslog, but it may work differently in your environment.

(Zoe) #5

I checked and I don’t think fdbmonitor is running after installation.

In my setup the logs are located at /var/log/secure but I don’t see any error message, here’s the log,

May 30 21:07:16 ip-100-90-28-158 sudo: ssm-user : TTY=pts/2 ; PWD=/home/ssm-user ; USER=root ; COMMAND=/bin/rpm -Uvh foundationdb-clients-6.1.8-1.el7.x86_64.rpm foundationdb-server-6.1.8-1.el7.x86_64.rpm
May 30 21:07:16 ip-100-90-28-158 groupadd[10126]: group added to /etc/group: name=foundationdb, GID=494
May 30 21:07:16 ip-100-90-28-158 groupadd[10126]: group added to /etc/gshadow: name=foundationdb
May 30 21:07:16 ip-100-90-28-158 groupadd[10126]: new group: name=foundationdb, GID=494
May 30 21:07:16 ip-100-90-28-158 useradd[10131]: new user: name=foundationdb, UID=495, GID=494, home=/var/lib/foundationdb, shell=/bin/false

Thanks!

(A.J. Beamon) #6

Interesting, that sounds like it may be a bug. Are you able to start the foundationdb service? If you do, does fdbmonitor start running?

(Zoe) #7

I get the error foundationdb: unrecognized service. Seems like the installation is not complete.

Also I just tried to download the ubuntu package at https://apple.github.io/foundationdb/downloads.html, but it returns a 404 error…

(A.J. Beamon) #8

I’ve created an issue regarding the rpm installation failures, and we’re working to update the bad links on the website for the deb packages.