Errors building for Go

Using 7.1.31 I am following the instructions found at foundationdb/bindings/go at main · apple/foundationdb · GitHub but I am encountering the same error as bindings/go: error "No rule to make target fdb_c_options.g.h" · Issue #5613 · apple/foundationdb · GitHub which is supposedly solved already.

I am running the install like: bash install --fdbver 7.1.31
on ubuntu 22.10

The error is:

root@fdbclient:~/fdbtest# bash install --fdbver 7.1.31
Directory /root/go/src/ already exists ; checking out appropriate tag
git -C /root/go/src/ fetch origin
git -C /root/go/src/ checkout 7.1.31
HEAD is now at 94e42d5c6 enable AVX and update version for 7.1.31 release
Building generated files.
make -C /root/go/src/ bindings/c/foundationdb/fdb_c_options.g.h
make: Entering directory '/root/go/src/'
make: *** No rule to make target 'bindings/c/foundationdb/fdb_c_options.g.h'.  Stop.
make: Leaving directory '/root/go/src/'
Could not generate required c header

I’ve noticed the file is not there:

root@fdbclient:~/fdbtest# ls /root/go/src/
ClientWorkload.h  fdb_c.h  fdb_c_internal.h  fdb_c_types.h

but it’s here:

root@fdbclient:~/fdbtest# ls /usr/include/foundationdb/
fdb.options  fdb_c.h  fdb_c_options.g.h  fdb_c_types.h

Does anyone know what I should be doing here to resolve this? Thanks!

Mmmm noticing now that perhaps version 7 is not supported: FoundationDB C API 2.0.x-6.1.x

Yep this was the issue, 6.3.25 works fine