Fdbrestore failing with below error


(Samir) #1

Fatal error : Attempted to restore into non-empty destination database

Command used fdbrestore start -r


(A.J. Beamon) #2

The restore tool does not support restoring a backup into a database that isn’t empty, so you will first need to clear all of the data out of your database if you want to restore into it. This can be done in fdbcli by executing the following command:

fdb> writemode on; clearrange "" \xff

Of course, don’t execute this command unless you are sure you don’t need the data in the database.


(Samir) #3

I tried the same but still shows same error


(Steve Atherton) #4

Might you have an application still running that is writing to the database?


(Samir) #5

There is no application running I am just testing with document layer running on top of my foundation database , Is that makes a difference ?


(A.J. Beamon) #6

The document layer could very well be writing keys to the database and interfering with your attempt to restore. Try stopping the layer, clearing the database, running your restore, and then restarting the document layer. Hopefully that sequence should work.


(Samir) #7

You are right after stopping document layer , I was able to restore the DB , Thanks